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General Information

Chapter 1
General Information

About DSE 890 installation, connecting to a drive, and launching DSE890.

¢ Introduction

¢ DSE 890 Installation

¢ Connecting to the Drive

¢ Launching DSE 890
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Introduction

DSE 890 (Drive System Explorer) is the software tool for the new 890 range of drives available from SSD
Drives. It can parameterise, configure and program both the 890CD Common Bus Drive and the 890SD
Standalone Drive.

Using straightforward block programming you can very quickly become a confident user of DSE 890.
Users of LINK and DSD (Drive System Designer), our two previous products, will appreciate DSE 890's
similarity with DSD and familiar features.

However, DSE 890 is new. A major concept is that of having three environments: Motor Control,
Application, and the I/O Elements:

Motor Control: this is a fixed environment comprising
drive and motor parameters organised into blocks. Youcan  |DSE890
parameterise these blocks, or you can read and write to
them by linking their parameters with blocks in the

890 configuration/application

Application environment. |/O |{Block Moto

r
Application: this is the working space, external of the /O Control
Motor Control environment. In it you can place any number

of instances of any block - gone are the days of fixed
numbers of blocks. Beyond that, the DSE 890 world is not
flat - you can create well structured, multi-layered

applications using the Macro feature, which allows you to Application
create a compound block representing an entire block

diagram. Motor

I/0 Elements: this is an illusionary environment where all Control
the drive's I/O is gathered. However, you do see this I/O
bought out in the relevant blocks in the Application
environment.

DSE 890 Configuration Tool



General Information

DSE 890 Installation

The 890 Drive is supplied with a CD containing the DSE 890 Configuration Tool. You can install DSE 890
on any PC with the following minimum specification:

¢ Windows XP, Home or Professional Edition
¢ 100MbD of free hard disk space

Insert the CD and execute the "setup . exe" file on the disk to install the latest LINK database and DSE
890. Follow the on-screen instructions.

Installing the USB driver

The DSE installation program "setup . exe" will copy the Texas USB driver files into the appropriate
Windows directories. When connecting the 890 drive for the first time, Windows will acknowledge that it
has found new hardware with the "New Hardware Found" wizard. When prompted for a driver, select the
"Install automatically" option and select "OK".

Note Windows will actually prompt with "New Hardware Found" twice.
This is the expected behaviour of Windows.

The DSE 890 installation program "setup . exe" will also install a copy of the Texas USB drivers into:
C:\Program Files\Texas Instruments\USB-Serial Adapter

If the automatic install method fails, select the "Browse" option and select the directory above once
prompted for a driver by the Found New Hardware Wizard.

Note The wizard will actually prompt for files twice. Point it to this same directory both times.
This is the expected behaviour of Windows.

DSE 890 Configuration Tool Page 1-3
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If you have already plugged in the 890 Drive and Windows has determined it to be an "Unknown/Other"
device, you must select the device in the Windows Device Manager (under the Unknown/Other Device
Class). Display the properties for the device (by double-clicking it), and then click the "Update Driver"
button on the "Driver" properties tab. This will then bring up a Wizard and you need to point to the
directory of driver files as described previously.

Note The wizard will actually prompt for files twice. Point it to this same directory both times.
This is the expected behaviour of Windows.

Updating the USB driver

To update the USB driver from Windows Explorer, go to MyComputer (Right Click) = Properties -
Hardware = Device Manager = Multi-port serial adapters = TUSB3410 device—>(Right Click) =
Update. If this does not work, you have to manually uninstall the older version of the USB driver first:

1.

A

v X e

Open MyComputer (Right Click) = Properties = Hardware = Device Manager = Multi-port serial
adapters > TUSB3410 device

TUSB3410 device (Right Click) = Uninstall.

Start = Run - regedit.

Go to HKEY LOCAL MACHINE/SYSTEM/CurrentControlSet/Enum/USB

If you have a Vid_0451&Pid 3410 this needs to be deleted

a. Vid 0451&Pid 3410(Right Click) = Permissions = Enable Allow Full Control for you = OK
b. Vid 0451&Pid 3410(Right Click) = Delete.

Go to HKEY LOCAL_ MACHINE/SYSTEM/CurrentControlSet/Enum/umpport

If you have this key, it needs deleting. Follow 5a and 5b to delete this key.

Delete umpusbxp . * and umpcomxp . * in windows/inf directory

Delete all of the oem* . * files that link to umpusbxp.inf and umpcomxp.inf. You need to do
this manually. Search string ump* . * and search files oem* . *

10.Delete umpusbxp.sys and ump£3410.1i51 files in windows/system32/drivers directory.
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General Information

Connecting to the Drive

Connect to the 890 Drive using a USB cable: A to mini-B. Connect the PC's USB port to the drive's X10
terminal. For a drive system, you can connect via USB to any drive in the system to gain access to all
drives. All drives in the system are linked via the FireWire Option.

For more information on the FireWire Option please refer to the FireWire Option Technical Manual.

Launching DSE 890

Start DSE 890 by clicking
its program icon in
Windows. Or, in the
Windows' Start Menu click
on "All Programs", you
will see "SSD Drives", and
within is "DSE 890". Click
on this to launch DSE 890.

DSE 890 Configuration Tool
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! Fle Edt iew Froject Command  Window  Help

Displays the Proj... # =

= B Recent Projects Displays the Properties View
@ & All Projects Document Settings
Global Settings

B Version

Appiersion 1.2
Form Wersion 42
Language English

Displays the Scratch Pad 3 x

DSE 890 wersion 1.24b13, Copyright 1985-2005 Parker 550 Drives. All Rights Re A |
Wed Jan 11 11:45:51 2006 R

Param... [ Projects |— < i | >
Ready Connected at 57600
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First Configuration

Chapter 2
First Configuration

How to create, modify and install a new configuration as well as going online.

Creating a Configuration

Modifying a Configuration

Installing a Configuration

Import/Export a Configuration

The Online Configuration
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First Configuration

Creating a Configuration

1. From the "File" menu, select "New". A Dialog will pop
up. Select a configuration, e.g. 890 Volts/Hertz, and
click "OK"

New Configuration

890 Active Front End oK
290 Closed Loop Vector (Default)

290 Permanent Magnet AC e

890 Sensorless Vector (Default)
890 Shaftess Printing
890 Voltz/Hertz (Default)

e 1

890 Regen mode, Regenerative Active Front End,

. User Input |x
2. When prompted, enter a new configuration name, —

c.g. "L890_1", and click "OK". Enter Configuation name:

l 0]14 ] l Cancel ]
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3. Here is your first configuration L§90 1*.

E3% DSE 890 - [LB90_1]

First Configuration

- BX

P Fle Edt iew Project Block Command Insert Format  Window  Help -8 X
ZE-ABED EEED 2ae0)
Projects - 00000... ¥ = rﬁago 1 4b x
=-H Recent Projects > .
= Public o —
=29 Standalone oY
BOOSHIP L
- ANINE Motor Contral AN OUT 1 -—
He 1 Mlecple =120 0% faamp INRUT SPEED 1205
=-H All Projects — Blorrser L% TR MpUT TORZUE] WMera e —
’ mme Fate ] oy RUNNING BlaFrser
= Public - ?“ STaRT ZERO SPEED L
ELLT Y HEALTHY |— 4N CUT?
=] Standalone NN —L8 o ey ERsE Loz
BA0SHIF — “:%SCHLE 1 ﬁﬁ':F':EEEr
- Blorrser 3
Laao_1 [ me
+10V
DI OUT 1
I Elcnaale .
10V Hatate
— 0NG OUT2
Benante | —] %
H 4 1of1 | - IES% v |+ 4 *
Scratch Pad - 00000890:Public /standalone o
loading 'LE90_1'(CASSD LINKACOMFIGSWO00008905L890 _1.001, mod. 1) ... done. ~
w
Param... B Projects a
Ready Cornected at 57600 ]

4. Save the configuration by clicking on File/Save or the Save icon, or select "Save" from the "File" menu.
This will create a new revision of the configuration, revision 1. The asterisk "*" against the name will

disappear.

DSE 890 Configuration Tool
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Modifying a Configuration

A configuration can be modified by editing blocks and links, and by inserting or deleting blocks.

Editing Blocks

You can view the contents of any function block in the
configuration by double-clicking the icon for the block. [ERURLERELLELFALARUEICIRLTTL D)
For example, double click on "AN IN 3" will open the
analog input function block 3.

100
Offset 0
Sample rate (ms) 100 ms

Where a parameter can be edited, click on the relevant
sub-menu [ to display the options (for enumerated and
boolean parameters), or edit the displayed numeric
value directly on the screen by clicking on the value.

When you have finished editing the block select "OK"
to exit the block, otherwise select "Cancel" to exit the gcal'e
block and disregard any changes you may have made. e

When you make any changes, save the configuration by ok | | cencel
clicking on the Save icon B, or "File->Save". This will
remove the asterisk ( * ) against the configuration name.

Editing Links

X AN N2 Motor Contral AN OUT 1
A link transfers the value of an mggg% SCALE X12-04 g:gg : RAMP INFUT SPEED e X1208
- S OFFSET 0 TRIM INPUT TORQUE  Doa]2CALE
output parameter to an input 200 ms Fase 108 L FUNNING OFFSET
AN IN & Falee AN OUT 2
parameter of another (or the 1000080, = yrzos Faa | S10F HEALTHY Py
DO0E I FEsET 100.00% o0 ¢
Same) block. 200 ms DO0%) oppsET
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Links are made by connecting an output to an input, in that order.

Hover the cursor over the output line until the cursor changes to an "x". At this
point, click and hold the mouse button. Now stretch the red link to the input
line. When the link turns green, you have a possible connection. To make the
connection, let go of the mouse button.

To make a link

To delete a link Click on the line. It will turn purple. Press the Delete key on your keyboard.

Click on the line and hold the mouse button. The line will turn purple. Now you

To reshape a link line can drag any part of the line in any direction.

Inserting New Function Blocks

You can insert any number of new function blocks into the Application. For example:
Click on the Block menu at the top of the screen.
1. Move the cursor down to select "Logic" and select "Counter".

2. Click to attach the block icon to the cursor. Move the icon to where you want on the screen. Click again
to release the icon.

3. To insert another of these blocks you can repeat the process or just Copy and Paste the original using the
Edit menu at the top of the page. (The standard Ctrl+C, Ctrl+V and Ctrl+X also apply).

Note For further details of all function blocks, refer to the 890 Engineering Reference manual, Appendix D.
Motor Control Block details are available in DSE 890 by right-clicking a function block in the Motor
Control Block pane and selecting "Help"'.

(] (]
Deleting Function Blocks
Select a block and press the "Delete" key. This will delete the block.
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Editing the Motor Control Block

Double-click the Motor Control Block. A new window will display the motor control block diagram.

225 DSE 890 - [L890_1-Motor Control]

! Fle Edt Wiew Froject Block  Command  Insert Format  Window  Help

ZH~Q BEEEERR =mEEA)

Projects - 00000890 * % (™35 1 1 890_1-Motor Control | ab x
= B Recent Projects =
=3 Public i
=43 Standalone REFERENCE
SA0SHIP REFERENCE REFEREMCE RAMP
SPEED DEMAND RAMPING
Lea0_1 SPEED SETPOINT LINEAR g atip TvPE

REVERSE 10s)ACCEL TIME —

B Al Projects LOCAL SETPOINT

LOCAL REVERSE
FWRE SETPOINT
SPEED DEMAND
RAMP INPUT 0% bEMOTE SETPOINT
TRIM INFUT 0% FEED TRIM

110 % |y SPEED CLAMP
% hiIN SPEED CLAMP
False lrpih 1N LOCAL

SDECEL TIME
False] e lMETRIC MODE
S S rMMETRIC TIME
TrueleramP CONTINUOUS
< SRAMP ACCEL

< SRAMP DECEL

2 SRAMP JERK 1

T T T T T T T T T T T T
-
o
i

REVERSE Faﬂ's\; REMOTE REVERSE 1'__03“;59— SRAMP JERK 4
1500 RphlfﬁmmrggEsEEDTpumT ¢ HOLD
REFERENCE STOP REFERENCE JOG
RUN RAME oy s1op MODE - 10 % e rpoINT -
10sl=10p TIME - 12 ACCEL TIME -
01 %= T0F ZERD SPEED |- 12 pECEL TIME -
055 ler0p DELAY -
Rﬁ;gZ—FAST STOP MODE [ v
Hod 10f7 (S - v | * |t >
Scratch Pad - 00000890:Public /Standalone o ox
done. A
Ioading template CASSD_LINKMONFIGSWEWASOCLDFT 003 B
done. =
saving 'L820_1' (CAS5D_LINKMWONFIGSW1000089MLE20_1.001, mod. 1) ... done. v
Farameters [ Projects | |[¢ | >
Ready Connected at 57600 L )
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Connecting Parameters to the Application

If a motor control block has to be written to or read from the application, Inputs and Outputs can be added
to the Motor Control block diagram, respectively.

REFERENCE
For example, to add a new input parameter called "REVERSE", T
open the Motor Control Block diagram, add a new input from the SPEED SETPOINT
Block menu, then rename it to "REVERSE" (shown connected to L BeAL REWERSE
REFERENCE /REMOTE REVERSE). "SPEED DEMAND

RAMP INPUT 0% | PEMOTE SETPOINT
TRIM INFUT 0% | cPEED TRIM
MOy p e SPEED CLAMP
0% N SPEED CLAMP
False ] e 1N LOCAL

REVERSE FED'S; REMOTE REVERSE

COMMS SETRPOINT
COMMS SETPDINTQ—,TRPM— hAs SPEED

On exiting, the motor Control Macro the additional input parameter Motor Cortrol
. . 0%
"SETPOINT" will automatically appear on the Motor Control block as o] TR NPT ToRGOE
. False | |ng RUNNING
shown on the I'lght. ::z: START ZERD SPEED
Falze EESERSE HEALTHY—
—COMRE SETRPOINT
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First Configuration

Installing a Configuration in a Drive

Once you have created your own configuration, you are in a position to install it in the drive. Select
"Command->Install At Selected" to install the currently opened configuration into a drive.

The installation is confirmed by the Scratch Pad - 00000890:Public/Standalone
Scratch Pad message.

[ »

Current serial number: 0448-UK-E-0020
Beginning download to: Link3 Module (MTID 2618)

The configuration is now installed into ARSI T TR . €8 CITE,

your drive.

=

Autotune

The configuration must be closed:

1. Trigger Autotune in the drive (via the MMI) and wait for it to be completed.

2. Select File->Update; this will update the parameters in DSE's copy of the configuration.
This will ensure that your DSE 890 configuration reflects exactly the state of the drive.

Import/Export a Configuration

Select " File>Export" in order to save a configuration at any location. This exported configuration can be
imported into DSE on another computer by using "File=>Import.

The Online Configuration
Opening the Default Configuration Online

If you did not install a configuration in the drive, select " File=>Open Online " or simply press "F9" to open
the default, shipping configuration in online mode.
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Opening a New Configuration Online

At this point, your configuration should be installed in the drive. Now, select "Command->Go Online" and
the configuration will be opened in online mode. Alternatively, you can select "File=>Open Online", or
simply hit "F9".

Working Online

The ONLINE configuration window looks the same as an OFFLINE
version, but has some extra features. Note that you cannot remove or

. . . AN 3
add blocks and links in online mode. ScALE 1204

OFFSET

When you hover the cursor over the output of a block, the cursor will 100 ms
change to the shape of a "cross". Shift-click puts the parameter into
the Monitor List. To read the value in the function block and the

scratchpad, just click. DSE 890 will get and display the actual value from the drive.

Mo 1of1

The Scratch pad will become visible and will display the retrieved value. The same happens if you click on
an input of a block while holding the "SHIFT" key.

If you want to change an input value of a function User Input B\
block, simply click on the block input while holding
down the "CTRL" key. This will bring up a dialog
prompting for the value to be set. For instance, clicking
on AN IN 3 : SCALE while holding the CTRL key will
open the following dialog.

Enter Scale:

QK l [ Cancel I
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DSE 890 Tools

Chapter 3

DSE 890 Tools

An explanation of the DSE 890 tools for working on configurations.

The ONLINE Configuration
e The Module List

e Scratch Pad

e The Monitor List

e The Chart Recorder

Introduction

The Properties View
The Scratch Pad
The Projects View

The Parameters View

e The Oscilloscope

The Configuration View
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DSE 890 Tools
Introduction

It is assumed that at this point you have launched DSE 890. The DSE 890 main window uses the standard
Windows menu bars, scroll bars, title bars etc. If you are unsure about these, consult your Windows
manual.

Main Views
DSE 890 comprises several graphical areas:

Properties View displays global DSE 890 properties

Scratch Pad displays a record of work performed by DSE 890

Projects View displays a list of projects and configurations organised into categories
Parameters View displays a list of all parameters in the active configuration

Module List use this to get online to a drive or drive system

Configuration View displays the configuration(s)

Monitor List use this to monitor parameters of a selected drive
Chart Recorder use this to monitor parameters of a selected drive
Oscilloscope use this to monitor parameters of a selected drive

All these views can be accessed through the DSE 890's "View" menu.

Working with Panes

Monitor List, Chart Recorder and Oscilloscope open as separate windows. All other Main Views are
dockable panes. Either they can be windows (floating panes), or they can be docked to an existing window
where they become a tab (docking pane). You can size and dock all areas and toolbars to wherever you
want in the DSE 890 window. To undock, click on a Pane Title and drag the pane to a desired place. At
first, the area will become a floating pane, but Windows will propose areas to dock the pane to. Releasing
the mouse then will dock the pane to an existing Window as a Tab.
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DSE 890 Tools
The Properties View

The Properties view allows you to configure the behaviour of DSE 890 through parameters organized into a
tree. Initially, the Properties View will display all items in the Version section.

Version

App Ver 'Si qn S Properties [x]
The application version is displayed and can not be changed.

Form Version B

This displays the version of the pane layout and can be used to | . version 42

reset the layout to the default settings. To reset the pane layout | Language English

to its shipping version, select "Form Version" and set its value
to 0. Then exit DSE 890. After launching DSE 890, the pane
layout is reset to its default.

Language
Select your language from the "Language" item.

Document Settings
These settings refer to a configuration's block diagram and how g
it is displayed: Snap to Grid, Grid Size, Block (colors for snap To Grid True

. . Grid Size 35, 35
selected, advanced and high performance blocks), Conngctlons Block Properties
(colors for connected, unconnected and selected connections). Commections Properties
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DSE 890 Tools
Global Settings

The list of Global Settings are mostly self-explanatory, but a few are explained in more detail below.

Serial Comms Port -
This will select the port your drive is connected to. If you have ~ User Mame AN. Other
selected the Comms port correctly, the Serial Comms Port g:;zrgzm:qpm ES;SBD—LINK\‘

description field in the Properties View will read "USB-Serial =~ sccess Moduie List at Start Up— True

Port". Murmber of revisions stored 10

Mumber of recent projects listed 1
o Mo Module List Update False

Access Modylg Ll;f at qurf Up . Save Lo e

The Module List is built and displayed when DSE is launched  Edit at oriine True

if this value is set True Drive parameter view level Engineering
Scratch Fad Font Arial; Bpt

o o Monitor List Font Arial; 10pt

Number of Revisions Stored Module List Fortt il Bpt.

This will set the number of revisions stored by DSE 890 for Blink time (n seconds) 10

each configuration. Whenever a change is made to a Frame Mode Maxdmize

. .. . Canfiguration Mode Block diagram orly
configuration document, a new revision is created, and the Configuration Description Fields
oldest revision 1s deleted. @ Project Description Fields

Number of Recent Projects Listed
This will set the number of recent projects displayed under "Recent Projects" in the Project view.

No Module List Update
The module list is not updated automatically after installation of a configuration.

Save Source
Set this True to save all source data into the drive when a configuration is installed. This enables DSE to

extract the configuration from the drive if it cannot find the project/configuration locally on the attached
PC.
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DSE 890 Tools

Edit at Online
True if a configuration can be edited in online mode.

Drive Parameter View Level

Set this to view Drive Parameters of a certain level. Each parameter has a viewing level attributed to it,
from "Operator" (basic operating parameters) to "Engineering" (high-end parameters primarily used by
SSD engineers).

Frame Mode
This will set how a configuration's block diagram is displayed: maximized or in a "frame per configuration"
block diagram.

Configuration Mode
This will add a list of parameters to the Configuration View when set to "Block Diagram and Parameter
Tree". The configuration view displays only the block diagram if this mode is set to "Block Diagram only".

Configuration Description Fields
You can set up to 6 description fields here. Double-click the required field (e.g. Field 1). Enter your new
text. These fields can be referenced in a Form that can be inserted in to a Configuration : Insert—=>Form.

Project Description Fields
You can set up to 9 description fields here. Double-click the required field (e.g. Field 1). Enter your new
text. These fields can be referenced in a Form that can be inserted in to a Configuration : Insert—=>Form.
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DSE 890 Tools

The Scratch Pad

The Scratch Pad reports the activities of DSE 890 to the user. When DSE 890 is started it will display the

DSE 890 version, the date, the user name and company DSE 890 is licensed to, together with the database
ID. You can enter today's date and time into the Scratch Pad: "Edit->Paste Time".

Displays the Scratch Pad

Accessing module list .. 3 done.

DSE 890 wersion 1.01, Copyright 1989-2003 550D Drives, Inc. All Rights Reserved.
Thu Jun 23 12:54:26 2005

Database 1D is 'Bidule Corparation’, user name is 'AN. Other!

Thu Jun 23 12:54:40 2005
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The Projects View

The Projects View displays a tree view of Categories, Projects and Configurations.

A DSE 890 Project can contain one or more Configurations. Often a project
contains many configurations to control a complete system (e.g. a group of DSE
890 drives supplied by SSD Drives for controlling the motors of a printing press).
You can also create configurations for any SSD Drives module supported by DSE
890.

DSE 890 Development only: By storing all related Projects in a Category you can
keep them in a logical grouping.

Project View Context Menus

Right-clicking a Configuration, Project or Category displays a menu of actions.

Recent Projects/All Projects Menu

Right-clicking the "All Projects" or "Recent Projects" displays a menu of
actions to the projects collection.

Note that if a Category does not contain a Project, the category name is

The Projects View displays all projects under the "All Projects" item, and

DSE 890 Tools

Projects - 99877863 x
=-H Recent Projects
=] Categary 1
=] Project 1
Laa0_1
=-H All Projects
=] Categary 1
[ Project 1
[C3 Public

Projects - 99877866
=8::fRecent Projects
=] Category 1 Mew Category
=7 Project 1
: : Leso_1| Hep
not stored in the SSD LINK database of projects. =B all Projects
=+ Category 1
[_ Project 1
the recently worked on projects under the "Recent Projects" item. You 3 Public

can change the number of recent projects displayed in the tree
(View=>Properties=> Global Settings=>Number of Recent Projects Listed).

DSE 890 Configuration Tool
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DSE 890 Tools

Category Menu (DSE 890 Development)
Right-clicking a Category displays a menu of actions applying to a
category.

This menu allows you to create a new project in a Category.

The creation of a new project will be reported in the Scratchpad.

Project Menu

Right-clicking a Project displays a menu of actions applying to a
project.

A few of these actions need explanation:

Page 3-8

New Configuration -brings up a dialog which allows you to
select a default configuration, e.g. Voltz/Hertz, and prompts for a
name.

Compact Project - executes "Compact Configuration" for the
whole project. Refer to "Configuration Menu" above.

Upgrade Project - executes "Upgrade Configuration" for the
whole project. Refer to "Configuration Menu" above.

Update Project - executes "Update Configuration" for the whole
project. Refer to "Configuration Menu" above.

Read Only - this toggles the read-only flag of the project.

Projects - 99877863 (=]
=B Recent Projects

=R | _ategory 1
=20 Project 1
L8350,

=B Al Projects
=+ Category 1

Mew Praject
Fename Category

Help

[_ Project 1
7 Public

Projects - 99877863 [x]
=B Recent Projects

=+ Category 1
ER=Froject 1
LBS0_;
=B Al Projects
=+ Category 1
[_ Project 1
7 Public

Mew Configuration
Rename Project
Compact Project
Upgrade Project
Update Project

Project Information

Read Cnly
v Sort by Address
History

Help

History - displays the revision history of all configurations of the project.
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Configuration Menu

Right-clicking a configuration displays a menu of actions

. ] Projects - 99877863 E]
applying to a configuration. = B Recent Projects
1 AN - =] Category 1
A few of these actions need explanation: = G Project 1
Compact Configuration - this deletes all old revisions of o [ AllProjects  Delete Configuration
this configuration that are not installed. HC] Caitsgeny i Rename Configuration
. (0 Project 1 Compact Configuration
Upgrade Configuration - upgrades all blocks in a (3 Public Upgrade Corfiguration
configuration to use the latest revision of the block. Update Configuration
Corfiguration Information
Update Configuration - updates the configuration using Read Orily
uploaded values from the drive. Histary
Read Only - this toggles the read-only flag of the Help

configuration.

History - displays the revision history of the configuration.
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Project View Actions

Similar to MicroSoft Explorer, you can navigate in the projects tree and perform certain actions.

Moving a Project
Grab a project by selecting it and holding down the mouse button, then drag the project to a different
category. Releasing the project item then will move the project category.

Renaming an ltem

Select a category, project or configuration, click a second time on it. The item will become editable. Now
you can change its name. Hitting enter will exit the edit mode and change the name.

Opening a Configuration
Double-click on a configuration in the Projects window to open the configuration. This may be either in its
own window (Normal mode), or maximized as a tab. You can change this behaviour in the Properties View.

Page 3-10 DSE 890 Configuration Tool



DSE 890 Tools
The Parameters View

The Parameter View (View—>Parameters) displays a tree-view of all blocks and parameters (where
applicable).

"All Parameters" contains a tree view of the entire configuration with all Parameters - Project 1/0890_1  [X]
blocks and all parameters in a hierarchical manner, i.e. it contains the top
level block diagram with all its blocks (a block can itself contain another
block diagram).

"Quick Setup" contains a tree view of a subset of motor parameters, for
example the CONTROL MODE.

In this view you can edit parameter values. For example:

1. Click the "+" next to "All Parameters" (or double-click the name). This 2

will display all the function blocks in the top level block diagram. System
ACCESS CONTROL
2. Click the "+" next to "ANIN3" (or double-click the name). This will = ANIN 3

Scale 100, 0000 %
Offset 00,0000 %

3. Double click into the value field of "Sample rate (ms)". SEmBIE e (M) | D00

display all the parameters of the analog input block 3.

EREONTIS

4. Change the value to the desired value.
5. Press enter. The value is now changed.
Another example:

1. Click the "+" next to "All Parameters" (or double-click the name). This will display all the function
blocks in the top level block diagram.

2. Click the "+" next to "Motor Control" (or double-click the name). This will display all blocks for the
Motor Control sub-system.

3. Click the "+" next to "Motor Data" (or double-click the name). This will all parameters for the Motor
Data block.
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4. Click the POWER to allow editing. You will see the

. Parameters - Standalone /L890_1
parameter reference number displayed, the full —

= MOTOR DATA

parameter path as accessed in the block diagram CONTROL MODE YOLTS fHz
hierarchy, and if applicable, the maximum/minimum SUPPLY VOLTAGE 350V TO 460
: POWWER, mm
Values and umits. BASE FREQUENCY a0Hz
5. Click into the value field to change the parameter value. MOTOR, VOLTAGE A400Y
MOTOR CURRENT 4,94
MAG CLURRENT 1964
. . . MNAMEFLATE RFM 14 20RFM
The Parameters View provides a convenient means to MOTOR, CONNECTION STAR
change parameter values throughout the configuration. MCTOR POLES 4POLE
POWWER, FACTOR. 0,78
WERLOAD 2
# TOTAL INERTIA Ckgm?2
#* STATOR RES 3.534800m
# | EAKAGE INDUC 73.01mH
Note that all firmware parameters can be referenced by a * MUTUAL INDUC 300.04mH

parameter reference (Pref) number in the format: * ROTOR TIME CONST 136.75ms
BLOCKNUMBER.PARAMETERNUMBER POWER

Parameter reference; 27.2
in 2 0.000000, Max @ 3000.000000, Units @ kW

You can read the parameter reference in the Parameters
View. For instance, the Parameter Reference for "MOTOR
DATA/POWER " would be "27.2".
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The Configuration View

The default configuration for the 890 is shown below. It contains the Motor Control block, the function
blocks required by the default Application and their links.

ssé LB90_1

8 +10V

9 | 10V

AN N3

SCALE  x1z2-04
OFFSET

==

0%

Motor Cortrol

0%

100 ms

Falze

AN N 4

Falze

Falze

Falze

SCALE X12-05
OFFSET

10 m=

= =]

DIG IN 1

Jm

ENABLE X15-01
STATE

DIG INZ

ENABLE X15-02
STATE

Jmm

DIG IN 2

ENABLE X15-03

Jm

STATE

P kA

P)I.— I

0%

RAMP INFUT
TRIM INFUT

COMMS SETFOINT

SFEED

AN OUT 4

TORQUE

RUNMIMNG ——
ZERO SFEEL [
HEALTHY

XA2-068
SCALE
OFFSET

=1\

AN OUTZ

XAZ207
SCALE
OFFSET

==

OIG OUT 1

X145-08
ENABLE
STATE

[mm

DIG OUT 2

X15-00
ENABLE
STATE

[mm

DIG OUT =

HAER
ENABLE
STATE

[mm

]
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X12

X15

ey

TORQUE

RUMNING

to PLC

ZERO SPEED

X14

HEALTHY

[ €
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Modifying the Configuration

A configuration can be modified by changing parameter values of existing blocks, adding new blocks, or
adding/deleting links between function blocks. In addition, graphical elements can be added to improve the
understanding of your configuration.

Function Block Properties

A block icon displays the Instance, Class Name and Parameter Name.
Inputs are shown on the left of the block, outputs are shown on the right.
You can use any number of the same type of block - another Instance of that block will be produced.

Rename the Instance name for the block by right clicking on the block and selecting "Rename".

Name and Instance
> CN.1 v Block type

COUNTER’
Jl INPUT =
- EG ™ | oo
Parameter
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Editing Blocks

You can view the contents of any function block in the

configuration by double-clicking the icon for the block.

For example, double click on "AN IN 3" will open the
analog input function block 3.

Where a parameter can be edited, click on the relevant
sub-menu [J to display the options (for enumerated and
boolean parameters), or edit the displayed numeric
value directly on the screen by clicking on the value.

When you have finished editing the block select "OK"
to exit the block, otherwise select "Cancel" to exit the
block and disregard any changes you may have made.

DSE 890 Tools

222 AN IN 3 (355387.001:Analeg Input 3)

=
Scale 100, 0000 %
Offset 0,0000%
Sample rate {ms) 200.00 ms
| )8 | l Cancel ]

When you make any changes, save the configuration by clicking on the Save icon B, or "File->Save". This
will remove the asterisk ( * ) against the configuration name.

Editing Links

A link transfers the value of an output parameter to an input parameter of another (or the same) block.

AMIH 3 Motor Control

100.00%]
0.00%]

SCALE X12-04 g'gg : RAMP INFUT
- TRIM INFUT

AN OUT 1

SFEED
TORQUE

RUNMING

ZERDO SFEED
HEALTHY

OFFSET e
200 ms JOG
Falze
START
AH N 4 False | e
mggg%scmj *12.05 False | pEvERSE
O0% QFFSET
200 ms

Links are made by connecting an output to an input, in that order.

DSE 890 Configuration Tool

2 AZ-06
SCALE
OFFSET

AN OUTZ

100,00 %]
0.00%]

xAZ07
SCALE
OFFSET

100.00%)
0.00%]
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Hover the cursor over the output line until the cursor changes to an "x". At this
point, click and hold the mouse button. Now stretch the red link to the input line.
When the link turns green, you have a possible connection. To make the
connection, let go of the mouse button.

To make a link

To delete a link Click on the line. It will turn purple. Press the Delete key on your keyboard.

Click on the line and hold the mouse button. The line will turn purple. Now you
To reshape a link line | can drag any part of the line in any direction. Click away from the line to
deselect it. The line will turn black.

This allows you to split a link on a page or between different pages of the
configuration.

To split a link on a page:
Make the link (as above). Double click on the link to select it. It will turn
purple and a message box will appear. Confirm to split the connection.
To split a link The link will be split with the relevant text pointers.

To split a link between different pages:

Make the link (as above) but, while holding the mouse button, click on

mprfe ¢ TofS o Thig will open the next page and allow you to
connect to an input on that page. The link will be made with the relevant
text pointers.
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Inserting New Function Blocks

You can insert any number of new function blocks into the Application. For example:
Click on the Block menu at the top of the screen.
4. Move the cursor down to select "Logic" and select "Counter".

5. Click to attach the block icon to the cursor. Move the icon to where you want on the screen. Click again
to release the icon.

6. To insert another of these blocks you can repeat the process, or just Copy and Paste the original using
the Edit menu at the top of the page. (Ctrl+C to copy, Ctrl+V to paste, and Ctrl+X to cut selected text

also apply).

Note For further details of all function blocks, refer to the 890 Engineering Reference manual, Appendix D.
Motor Control Block details are available in DSE 890 by right-clicking a function block in the Motor
Control Block pane and selecting "Help"'.

Deleting Function Blocks
To delete a block, select the block and press the "Delete" key.
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Macro Blocks

An important feature of DSE 890 is the use of the Macro Block. These blocks can be used to run a portion
of the application. Because the blocks can be layered, the entire application can be organised in a
hierarchical and structured manner. (The Motor Control block is in fact a Macro block).

To insert a Macro block, go to the Block menu and select "Macro".

pst LB9O_1

MACRD. 1

E3% DSE 890 - [LB90_1]

P Fle Edt iew Froject | Block | Command  Insert
ZH A EEE e

Cutput
| Macro |

As aresult, a new Macro block will be added to your configuration. Double click on the block to open the
new, empty diagram. You can add blocks (including further Macro blocks) and links as usual. In addition,
you may add input and/or output blocks from the "Blocks" menu using "Input" and "Output" respectively.

Adding one input and one output and connecting them together would create the following diagram. Note
that the input and output will automatically appear as additional ticks on the Macro block icon.

pst LB90_1-MACRO. 1

bst LBSO_1 |:HE\8|
.Y

MACRD.1 o
INFUT.?  OUTPUT.Z—

INFUT.? OuTPUT.Z
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Network 1/0 Blocks

DSE 890 Tools

When in the main, or top level diagram, selecting "Input" or "Output from the "Blocks" menu will create a
Network input or output respectively. You must provide the node ID of the source as well as a slot number,

which acts as unique identifier.

Link Input

Lirk Inpuk

Source: | 1

Description: | Counter Ir

o ][ coeol |

Link Output

Link Output

Dest, Address:

Slot Murnber:

Description: ‘ Coumter Outl

oK Cancel

The Description field will become the input/output block name (Instance).

Counter In{

CH.1

COUNTER
{NPLIT

1=

DIRECTION
RESET

1 1 1Counter Out

Connecting Parameters to the Application

Refer to "Connecting Parameters to the Application" on page 7.

DSE 890 Configuration Tool
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Inserting and Creating Forms

DSE allows to add forms to a configuration. Either you can ad an existing form through the menu "Insert ->
Forms -> Name of the form to be inserted", or you can create a new form.
If you want to create a new Form, select menu "Insert -> Forms -> Create ..." which will pop up a dialog:

Enter new name for Form

[ QK l [ Cancel I

After entering a name, e.g. "Form 1" and selecting OK, an empty Form will be created.

95t LE90_1-Form 1

Using the Drawing Toolbar you can add any drawing element.
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The ONLINE Configuration

Note You cannot remove or add blocks and links in ONLINE mode.
To go ONLINE, refer to page 2-8.

The ONLINE configuration window has "ONLINE" displayed in the title, but otherwise the window looks
the same as the OFFLINE version, but it does have some extra features.

Move your cursor over the "tick" of the parameter in the function box and the cursor will change to an "X".
Now you can:

Scratch Pad - 00000890;Public /Standalone

e Click the input or output of a block to display the T
actual Value from the drlve ln the Scratchpad. --» 00000390 8390SHIPAAN IN 3:2412-04 . 0.4990%

Ea
v
4 | 3

e SHIFT-click the output of a block to add that
parameter to the Monitor List.

AN

BO00% srn B w1204 (00
BO0% nFFSET

100 m= ’—
W

1o0f1

e CTRL-click the input of a block to change the parameter value.
This will bring up a dialog prompting for the value to be set.

e Right-click a parameter to display a menu of actions applying to the
parameter (right-clicking a parameter in the Parameters View has the same effect):

Get Display the parameter value in the Scratchpad. 10000 e e 0 0o ]
Monitor  Add this parameter to the Monitor List R ot
Chart Add this parameter to the Chart Recorder "Cm?f
Scope Add this parameter to the Oscilloscope. Scope

Note that in all cases the Scratchpad will display the latest value.
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The Module List

Page 3-22

Note

This displays all the modules that are connected to the PC and allows you to select the drive to go ONLINE
with. Select "View—>Module List". By default it will appear in the bottom right of the screen.

If you have connected a single drive, then this drive will be seen in the module list.

Adrs | Name Litrary Status CPU % | Hea . hsofs Errs
*0001 890SHIF 890 w1 B Ok - Met Fail 2.0 10.2 0 0

If you have a drive system connected together using the FireWire Option(s), the drive your PC is connected
to directly will be the first in the list. It will have the network address of 0001. The first module in this list
will automatically be selected and be marked with an Asterisk.

Adrs | Mame Library Status CPU % Hea.. Msois Errs
*0001 890SHIP 890 v1.6 Ok - Met Fail 2.0 10.2 0 0
0002 8905HIPZ 890 v1.6 Ok - Met Fail 2.0 10.2 0 0

The Projects View will display an install flag """ against a configuration to indicate the configuration
in use by the selected module.

If your drive is not displaying in the Module List:
e Check the connection between the PC and the connected drive
e Check the FireWire cable connections if a system drive

e Check the FireWire Option is inserted correctly into the front of each system drive
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Module List Information

Address
Name
Library
Status
CPU%

Heap %

Message/s

Errors

DSE 890 Configuration Tool

Displays the Net Address for the connected drive (Edit—=>Net Address)
Displays the name of the configuration in use by the selected drive
Displays the library name for the configuration

Displays the status of the selected drive

Indicates the amount of CPU activity, or how busy the microprocessor was since the last
execution of a module list. This information is also available if a "Command—> Get Info" is
performed.

Displays how much static RAM (SRAM) the module's CPU has used since the module last
entered the OK state and began executing the installed configuration. This information is also
available if a "Command->Get Info" is performed.

(Messages/second) This is the average number of messages per second of network traffic the
selected module receives. This information is also available if a "Command—>Get Info" is
performed.

This 1s the sum of fragments, CRC Errors and overruns

Fragments: Messages received by the module that are shorter than the 72 bits
required.

CRC Errors (Cyclic Redundancy Check word) Bad checksums on messages received
into the Link module.

Overruns: Messages received by the Link module are longer than the 72 bits required
This information is also available if a "Command—>Get Info" is performed.

The Fragments, CRC errors and Overruns values should all be zero. On occasion you may
see 1 or 2, but normally the numbers in these registers should be zero. If they continually
count up, there may be a problem with the network.
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Scratch Pad Module Information

Selecting a module in the Module list, then selecting "Command->Get Info" will enter "Module
Information" into the Scratch Pad.

Scratch Pad - 00000890;Public /Standalone

Serial number: 0448-UK-E-0020

Project:  00000820:Public/Standalone

Configuration: 8905HIP

Type: 890 Link3 Module (MTID 2818, Library RD470590.001)
Modification: 1

Permanent address: 1

working address: 1

Persistents used:  4.5% (23)
CPU used: Recent 14 9%, Peak 17.3%
Heap used: Static: 11.8%, Peak 11.8%
Messages/s 0

Status: Ok - Net Fail, drive not running

Serial Number Displays the serial number for the selected drive

Project Displays the "project number: category name/project name" for the selected drive

Configuration Displays the name of the configuration in use by the selected drive

Type Displays information about the type of module selected including library
information

Modification Displays the revision number installed

Permanent Address Displays the permanent network address

Working Address Displays the working network address

Persistents Used
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Amount of persistent memory used
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CPU Used Indicates the amount of CPU activity, or how busy the microprocessor was since
the last execution of a module list. This information is also available in the Module
List

Heap Used Displays how much static RAM (SRAM) the module's CPU has used since the

module last entered the OK state and began executing the installed configuration.
This information is also available in the Module List

Messages/s (Messages/second) This is the average number of messages per second of network
traffic the selected module receives. This information is also available in the
Module List

Status Displays the status of the selected drive
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The Monitor LiS‘l’ B DSE 890 Monitor List

The Monitor List displays all the drive parameters that you are =H[oe n A

. . . Parameter “Wallg
monitoring and continuously gets updated values from the AN N 3-X12.04 (B90SHIP / 000008... 0.1755
drive.

The Monitor List Toolbar

The toolbar contains several buttons:

T

Open saved Monitor List configuration from a file.

Save Monitor List configuration to a file.

0 @

Toggle the Monitor List to be on top.

2 Start recording to a file.

Stop recording.

A Change the font of the items in the monitor list.
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Adding Parameters to the Monitor List

You can add a parameter to the Monitor List either from an ONLINE Configuration or from the ONLINE
Parameter View, e.g. adding the analogue input 3 ANIN 3 results in the following Monitor List. Parameters
from several drive nodes (or modules) in a drive system can be monitored in the same list.

You can easily remove a parameter from the Monitor List by a right click and selecting "Delete".

BN DSE 890 Monitor List =]
== NE=1C
Parameter WalUe
AN N 31 2-04 (BE__'éaa'bl_e____}.. 0.2274
Disable

"Set", I available for this parameter, brings up a dialog to change the value. "Enable and Disable allows this
parameter to Enabled or Disabled from being updated in the Monitor List.

Monitor List Information
"Parameter" displays the configuration name/instance/parameter name

"Value" displays the current value, constantly updated.

DSE 890 Configuration Tool Page 3-27



DSE 890 Tools
The Chart Recorder

The Chart Recorder displays the values of the selected parameter(s) and continuously gets updated values
from the drive.

Here is a typical chart. It shows one parameter, analogue input 3 AN IN 3 .

Bl DSE 890 Chart View

@ WSO/ p Il on

Time base [5] 20.00 9 _______________________________________________________________
Chart Mode False abo N N N N N N N N N
¥ axds aUtorm atic True ? _______________________________________________________________
E i _______ T-="="=" % _______ T-="="=" T-="="=" T-="="=" T-="="=" T-="="=" T-="="=" T-="="="
Background color [] 255; 255; 2 5 -------
Grid color Moo S 5 S S S S S S
. 3f- e booneees e e e e e e e
= ooooosaoLsso_t/an N 3 [l 255; 0; 0 T S S S
Offset 0.00 T [ b b b free F F F F
S B T
Active True T [ [ [ [ [ [ [ [ [
et z B e e —-—ee Hikit-:2:1
e foeennns fooeee foeennns foeennns foeennns foeennns foeennns foeennns foeennns
S S
5 ...............................................................................
B R e it SEE T EEEY LT P T SR E TP P T T T EEE EPEEP T SEPEEES
7 ...............................................................................
-
9 ...............................................................................

104 : : : : : : : : :

0 2 4 B &} 10 12 14 16 18 20
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The Chart Recorder Toolbar

The toolbar contains several buttons:

=  Open saved oscilloscope data or configuration from a file.
H  Save captured oscilloscope data and configuration to a file.
&  Print oscilloscope plot.

2 Toggle the Chart Recorder to be on top.

Display/Hide the property grid.
»  Restart data acquisition.

I Pause data acquisition.

* Start recording to a file.

§ Stop recording.

Adding Parameters to the Chart Recorder

You can add a parameter to the chart recorder either from the ONLINE Configuration or from the ONLINE
Parameter View.

Parameters from several drive nodes (or modules) in a drive system can be charted on the same chart.

Setting-up the Chart Recorder

The Chart Recorder displays menus for Settings and Channels.
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Settings
"Settings" displays the settings for how the chart recorder displays the .
information. Time base [s] 20.00
Chart Mode Falze
Y axis automatic True
Background color I:l 255; 255; 255
&rid color Mo oo
Time base [s] : This is the time period shown by the chart (x axis)
Chart Mode :  When False the chart redraws at the end of the time range; when True the
chart scrolls continuously
Y axis automatic : When False the Y axis is set by "Y axis min" and "Y axis max"; when True
the Y axis is set automatically
Y axis min : Sets the minimum Y axis for the chart
Y axis max : Sets the maximum Y axis for the chart
Background color : Background color of the chart
Grid color : Foreground color of the chart
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Channels
"Channels" lists the current parameters being charted. Every parameter is
listed by parameter name. You can also set a display color for each

= an N 3/em N 300,00l 255; 0; 0

Offset 0,00
parameter. Cair 1.00
Active True
Pen width 1
Offset : The Y axis offset
Gain : The Y axis gain (amplitude, multiplier)
Active : False suspends the charting for this line, True activates the charting
Pen width : Sets the line thickness of the charted line (note that the order of parameters
in the list determines the drawn order on the screen - the last parameter to
be added is uppermost)
You can delete a parameter from the chart by right-clicking on its name -
and selecting Delete. S| 21 TN 374N i T W
Of.&e‘: Set
=ain
Active True
Fen width 1
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The Oscilloscope

The Oscilloscope will set-up a real-time data acquisition facility inside the drive firmware, wait for data to
be ready, retrieve the data and display it. This is a tool to capture and display fast signals from external or

internal triggers.

Shown below is a
typical chart,
"FEEDBACKS/SPEED
FBK %" with
parameter reference
"70.6".

All parameter values
are normalised into 10
divisions in the main
display area. Time is be
displayed in
milliseconds.

"Measurement", at the
bottom of the screen,
displays measured
values such as
minimum, maximum
and RMS. In addition
this is the display area
for the cursors.
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Bl DSE 890 Oscilloscope
EEHSB([D]« >0 x A

+ [

[l

= LE30_1
SetLp
= Channels

B FEEDEBAL

Active
Axis
FMaximurm
rinirmum
Pen width
Camment
= Advanced
Oiffset
Gain

Mode 0001

True
Altomatc
1.00

0,00

1

0,0000
1.0000

FEEDBACKS / SPEED FBK %0
Parameter reference: 70.6

Channel added

Measurements
hlir

hlax

hear

RiS

p2pP

Lea0_1/FEEDBACKS ! SPEED FBK %, Gain: 1.000000, Offset:0.000000,

0.0000
0.0000
0.0000
0.0000
0.0000

#1

dx
i1
Y2
4@

0.0000
0.0000
0.0000
0.0000
0.0000
0.0000

1
Y2
a4
K@
HEY2
dREY

0.0000
0.0000
0.0000
0.0000
0.0000
0.0000
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The Oscilloscope Toolbar

The toolbar contains several buttons:

Adding Parameters to the Oscilloscope

x =@ ¥l 0 F b @ &

|

Open saved oscilloscope data or configuration from a file.

Save captured oscilloscope data and configuration to a file.

Print oscilloscope plot.

Copy oscilloscope plot to clipboard

Toggle the Oscilloscope to be on top.
Display/Hide the property grid.

Download the oscilloscope set-up to the drive.
Manually hold the data if no trigger has occurred.
Stop polling for the status.

Upload the data once available for upload.

DSE 890 Tools

You can add a parameter to the Oscilloscope either from an ONLINE configuration or from the ONLINE
Parameter View, e.g. adding the speed feedback in rpm from MOTOR CONTROL / FEEDBACKS /
SPEED FBK RPM result in the following oscilloscope view.

Note that only firmware parameters can be scoped.

DSE 890 Configuration Tool
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Another way to add parameters to the oscilloscope is to right-click on "Nodes", which will bring up a menu
with three choices:

Add Address Add a physical address in the firmware to scope

Add Address
Add Special Add a special parameter from a pick list Add Special ‘
Add Pref
Add Pref Add a parameter reference number
In all three cases you will be prompted to enter the module Select Special Address X
node number with a dialog. —
! Electrical Angle -

! Electrical Frequency : :
: Speed Demand
! Speed Feedback Cancel
: Speed Integral
: Torgue Dermand
: Q-dwis Current Dermand (ig)
: Q-Awis Current Feedback (ig)
: Magnetising Current Demand (imr)
: Magretising Current Feedback (imr)
: D-Axis Current Dermand (id)
» D-Axis Current Feedback {id)
: Motor Current Feedback
: DC Link Yaolts
: Motor Terminal Yolts
: Firewire Dermand Timestamp
. Firewire Position Demand
. Firewire Speed Dermand
. Firewire Acceleration Demand
: Encoder Load Position Timestap
: Encoder Load Position
. Total Position Demand

+ Pociti;m Error

o In the case of Add Address, you will be prompted to enter
a memory address as a hexadecimal number, e.g. 0x0010.

e In the case of Add Special, a pick list will appear, show
opposite. This pick list will depend on the type of
configuration, e.g. Permanent Magnet Motor
configuration will be different from a Volts/Hertz one.

Lo s I Ly [ O T I L]

o e
WO

e In the case of Add Pref, a dialog will prompt for a
parameter reference number, which expects the format:

BLOCKNUMBER.PARAMETERNUMBER

I N T S e S e
[l B N R I i

DUl N}
JEIN N ]
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Setting-up the Oscilloscope

The Oscilloscope displays menus for Settings, Cursors and Nodes. The oscilloscope facility will do nothing
until it is set-up.

=
Description
H Shiow Legend Trie
Seitl n gs . . . Time Scale Milliseconds
"Settings" displays the settings for how the oscilloscope displays the Cyelie Mode False
information. Background color B 120
Grid color [ ] 255; 755; 0
Description : Description printed in the legend
Show Legend : Show legend in plot
Time Scale :  Time scale on plot x axis
Cyclic Mode :  Carry out data acquisition in a cyclic manner
Background color : Background color of the scope
Grid color : @Grid color of the scope
Cursors 5
" " : Active Both
Cursors" controls the cursors for X and Y axis. el L0, 1/REFERENCE /
Active . Select None, Horizontal, Vertical or both cursors
Channel : Select the channel the cursor should apply to
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Axes

"Axes" are named axis for the plot that can be added by the user.

Each plotted channel comes with its own axis. In order to group several

channels into one axis, a named axis can be added and its minimum and = Mamed Axis M 0 0; 255
. . Maxirmurm 1.00

maximum values can be specified. A 000
Maximum : Sets maximum value in the data display area
Minimum : Sets minimum value in the data display area

Nodes

"Nodes" lists in hierarchical order the parameters to scope for each node. -

Once a parameter has been added to the scope, a node will be added H Setup

automatically. The node name will be the name of the corresponding # Channels

configuration.

Each node entry will then contain a "Setup" item and a "Channels" item.

DSE 890 Configuration Tool
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Setup
"Setup" contains all the information to set up the data = Setup

s e s o . Trace Mode Trigger
acquisition facility in the drive. Trgger Direction [N Tigger

Trigger Source FEECBACKS f SFEED FBK
Trigger Value 0.0000

Trigger Location O

Sample Mumber 100

Sample Rate 1
Sample Period  ms

Trace* Mode Hold Trace on Trigger, Start, Stop or Full

Trigger Direction Falling, Rising or no trigger

Trigger Source Pull down list of available parameters

Trigger Value Numerical value of parameter to trigger on

Trigger is Real Value If true the raw data are scaled.

Trigger Location Location in % of the entire data sample where the trigger is expected.

Sample Number Number of samples to be acquired

Sample Rate Sample rate in period defined next

Sample Period Sample period, either milliseconds, or on the fastest task in the firmware, the

pattern generator.

* The term "trace" is used as a synonym for "data acquisition".
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Channels
"Channels" controls channel configuration and contains a = Channels B s o
"Channel" entry per parameter using the name of the parameter. 9 FEEDBACKS / SPECM 299, 0,0
: ACtve True
This entry also sets a color for the parameter. s R
Maximum 1.00
Mirimem 0.00
Pen width 1
Comment
= Advanced
Offset 00,0000
Gain 1.0000
Type : Type can be either value, i.e. a real data type, or an integer.
Active . False suspends the display and setup for this channel
True activates the display and setup.
Axis : The Axis can be assigned automatically, manually with minimum and
maximum specified, or assigned to a named axis.
Minimum : Sets minimum value in the data display area
Maximum : Sets maximum value in the data display area
Pen width : Sets the line thickness of the charted.
Comment : The comment added here will appear in the printed version
Offset : Sets the offset of the channel
Gain : Sets the gain of the channel

= Channels

A parameter (channel) can easily be removed by a right click on the EE ol >s00 0
- =l i =

parameter and selecting "Delete". ot
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Using the Oscilloscope

1. Set the Trace Mode.
2. Set-up the trigger conditions: Trigger Direction, Source, Value, and Type.
3. Set the Trigger Delay (the percentage of total number of samples occurring before the trigger).

4. Set the Sample Number (the total number of samples to be captured)

Total Number of Samples

Trigger location (%)

>| /\/trigger

[ " time

5. ® Download the oscilloscope set-up to the drive. This will begin the data acquisition.

6. When a trigger occurs, data acquisition continues until the total number of samples are acquired.
At this point, the trace facility will go into a HELD status.

7. DSE 890 will upload and display the captured data.
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Chapter 4
How-To

A quick list of common requirements and problems.

How-To

e How-To

DSE 890 Configuration Tool
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How-To
Install a Configuration

If you have created your own configuration, you need to install it in the drive.
There are two methods for installing a configuration:

1. Select "Command->Install At Selected" to install the currently opened configuration into a drive
selected in the Module List (a list of all drives that are connected to the PC).

2. Select "Command->Install At Address" to install the currently opened configuration at the Net
address for the drive (defined in the configuration, see XXX to change the net address.)

The installation will be confirmed by a Scratch Pad message.

Now the configuration is installed into your [yt B sse= T o ot e te = et

: : =
drive. Yoq are now the owner of this Current serial number: 0448-UK-E-0020
configuration. It cannot be edited by Beginning download to: Link3 Module (MTID 2818)

. Accessing module list ... 33 done.
another copy of DSE 890 without your ? v
consent.

Open a Configuration ONLINE

Double click on the selected module in the Module List to open the installed configuration into an ONLINE
mode configuration window. For details on working with configurations please refer to Chapter 3: "Chapter
3 : DSE 890 Tools".

Unless a new configuration has been installed previously, the default configuration (890SHIP) will be
opened. This configuration can be found in the Projects View under "All Projects/Public/Standalone".
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Install New Firmware

In the Command Menu, select "Install Firmware". A dialog will pop up which allows you to select a
firmware:

Install Firmyware R‘

Select Firmware: 890 Drive (version 1.4 firmware) v

290 Drive (version 1.4 firmware)
890 Drive (version 2.1 firmware)

Instal | ‘ Cancel |

Once selected, press OK and the firmware download will start. It may take a few minutes.
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Chapter 5
Toolbars & Menus

A listing of all DSE 890 toolbars and menus.

¢ Toolbars
_ ¢ Command Menu
¢ File Menu
_ ¢ Insert Menu
¢ Edit Menu
. ¢ Format Menu
¢ View Menu ‘
. ¢ Window Menu
¢ Project Menu Hel
¢ elp
¢ Block Menu

DSE 890 Configuration Tool
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Toolbars

Note DSE 890 uses the standard Windows toolbar controls for operating, sizing, moving and customising the
toolbars. If you are unsure about these controls, consult your Windows manual.

There are three default toolbars: "Standard", "Drawing" and "Text". You can customise these toolbars and
also create new toolbars. You can also undock them creating a floating toolbar.

The "Standard" Toolbar S EEREREEE

Open

0 &

Save

Full Screen

\£]

Magnify

Install at Address
Install at Selected
Install Changes
Restart Node
Halt Node

e 2

M H E

Identify Node

Get Info.
Module List
Monitor List
Chart Recorder
Oscilloscope

Pl

B B E

Page 5-2

Opens a new configuration. Select "New" to open one of the supplied configurations, or select
from your list of recently opened configurations.

Saves the configuration. An unsaved configuration displays an asterisk in the name.

Displays the selected configuration full screen. Other open configurations are displayed as tabs.
To return to normal view, select View\Full Screen.

Left click to zoom in, right click to zoom out. Click the icon again to disable the feature.
Installs the open configuration to the net address selected via Edit/Net Address.

Installs the open configuration to the drive selected in the Module List.

Installs changes to the configuration

Restarts the application in the drive selected in the Module List

Halts the application in the drive selected in the Module List

Identifies the drive selected in the Module List by changing the green flashing STATUS LED on
the drive to orange (for approximately 10 flashes).

Displays a set of information in the Scratch Pad about the drive selected in the Module list.
Refreshes and displays the Module List.

Displays the Monitor List

Displays the Chart Recorder

Displays the Oscilloscope

DSE 890 Configuration Tool



Drawing Information

DSE 890 allows to add drawing information to a configuration.
This can be done by two tool bars, the Drawing and the Text tool
bar.

The operation of these toolbars is very intuitive and similar to
many widely used programs. For this reason, the details of the
"Drawing" and "Text" toolbars are not explained.

The "Drawing" and "Text" toolbars can be used to annotate the
Configuration Window and the Motor Control pane. For example,
the blue diagrams in the default "New Configurations" are
produced in this way.

The "Drawing" Toolbar

ARROW, LINE, OVAL, RECTANGLE, IMAGE, LINE COLOR,
FILL COLOR, FRONT, BACK, GROUP, UNGROUP, PATTERN,

LINE WIDTH, LINE PATTERN.

The "Text" Toolbar

TEXT, FONT, SIZE, FONT COLOR, BOLD, ITALIC,
UNDERLINE, LEFT, CENTERED.

DSE 890 Configuration Tool
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Menus

File

New...

Open

Open History...
Open Selected
Open Online
Extract Selected

Ctrl+N

F2
F9

>

Close
Close All
Discard
Save

Save As...
Save All

Ctrl+S

Import
Update Selected

Print Setup...
Print Preview
Print...

Ctrl+P

Exit

Page 5-4

Fle Edit Wiew Project Block Command Insert Format Window Help - & X

Creates a new default configuration in the selected project

Opens a configuration from the selected project

Opens revision history of current configuration

Opens configuration of selected module in Module List

Opens configuration of selected module in Module List in ONLINE mode
Extracts selected items and save to a file

Closes the active window

Closes all configurations

Removes the configuration without saving

Saves the configuration

Saves the configuration to the same project using a new configuration name
Saves all configurations in the selected project

Imports configuration elements from a file

Updates configuration with parameter values from selected module

Setup your printing requirements

Shows how the page will print

Prints the active window

Closes this program

DSE 890 Configuration Tool



Edit

Undo

Ctrl+Z

Cut
Copy
Paste
Delete
Import
Export

Ctrl+X
Ctrl+C
Ctrl+V

Select All
Duplicate
Paste Time

Ctrl+D

Insert Sheet
Delete Sheet
Delete Form

Edit Form

Find Input...

Find Output...

Net Address (1)...

Performance
Standard
Advanced
High

Motor Wizard

F10
F11

DSE 890 Configuration Tool

Toolbars & Menus

Reverses your last action

Cuts the selected item from the window (to the clipboard)
Copies the selected item to the clipboard

Inserts the contents of the clipboard to the active window
Deletes the selected item

Import selection

Export selection

Selects all items in the active window

Duplicates the selected item(s)

Pastes today's date and time in the Scratch Pad

Insert a sheet into the configuration

Delete a sheet from the configuration

Delete a Form from list

Edit a Form from list

Find block input by name
Find block output by name
Sets the net address for the drive module in a drive system

Displays standard blocks in the Block Menu (black)
Displays advanced blocks in the Block Menu (green)
Displays high blocks in the Block Menu (green)
Launches the Motor selection wizard
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View

Full Screen F12
Magnify
Show Grid F7

Oscilloscope
Chart Recorder
Module List
Monitor List
Parameters
Projects
Properties
Scratchpad

Toolbars
Standard
Drawing
Text
Ladder
Status Bar

Forms

Page 5-6

Toggles full screen view by hiding toolbars etc.

Magnifies the configuration

Shows a drawing grid

Toggles the Oscilloscope view
Toggles the Chart Recorder view
Toggles the Module List view
Toggles the Monitor List view
Selects the Parameter View

Selects the Projects View

Displays the Properties menu for DSE 890
Toggles the Scratch Pad

Display the toolbars

Toggles the Standard toolbar
Toggles the Drawing toolbar
Toggles the Text toolbar

Brings up the Ladder Editor Toolbar
Toggles the Status Bar

Toggles Forms

DSE 890 Configuration Tool



Project

Recent

Manage...

Compact
Update...

Print...

Delete Configs...

Duplicate

Block

Input
Output

Macro

890

Winders

>

Note

DSE 890 Configuration Tool

Toolbars & Menus

Select from your Recent Projects in the Projects View

Displays the Manage dialog which allows you to organise Projects and Categories
Removes old revisions and temporary files from the active Category

Executes "Update Configuration" for the whole project

Executes "Print Configuration" for the whole project

Displays a dialog which allows you to delete selected configuration

Duplicate the project

Network input on top level diagram, else macro input
Network output on top level diagram, else macro output
Block representing a block sub-diagram

890 blocks

Winder blocks

The "Block" menu is only visible when a Configuration pane is on the screen.
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Command

Install at Address Ctrl+T Installs the open configuration to the net address selected via Edit/Net Address.

Install at Selected Ctrl+G Installs the open configuration to the drive selected in the Module List.

Install Changes F3 Installs changes to the configuration

Full Install at Selected Installs full configuration in selected drive

Go Online Go ONLINE with the currently opened configuration

Restart Restarts the application in the drive selected in the Module List ?

Halt Halts the application in the drive selected in the Module List

Identify Identifies the drive selected in the Module List by changing the green flashing
STATUS LED on the drive to orange (for approximately 10 flashes).

Get Info. Displays a set of information in the Scratch Pad about the drive selected in the
Module list

Refresh Refreshes and displays the Module List.

Upgrade Firmware Upgrade drive firmware

Set Serial Number Set serial number in drive firmware

Set Performance Level Set performance level for drive
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Insert

Text F4

Arrow F5

Line F6

Oval

Rectangle F8

Image

Form Create... »
Form X

DSE 890 Configuration Tool

Inserts a text box

Inserts a line with arrow

Inserts a line

Inserts an oval

Inserts a rectangle

Inserts a selected bitmap image file
Create a new Form in a new view

List of Forms to be inserted

Toolbars & Menus
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Format

Align

Text Font...
Text Face
Text Size
Text Color
Bold

Italic

Underline

Ctrl+A

Left Justified

Center Text

Line Color
Fill Color
Move to Eront
Move to Back
Group
Ungroup
Pattern

Line Width

Line Pattern

v

Page 5-10

Align drawing elements

Changes the font attributes of selected text
Select the typeface for selected text

Select the type size for selected text

Select the color for selected text

Toggles the Bold attribute for selected text
Toggles the Italic attribute for selected text
Toggles the Underline attribute for selected text

Aligns selected text to the left, ragged right
Centers selected text

Select the line color

Select the fill color

Move selected object in front of other objects
Move selected object behind other objects
Group selected objects together

Ungroup selected compound

Select a pattern fill

Select a line width

Select a line pattern

DSE 890 Configuration Tool
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Window

Cascade Arranges windows as separate tabs

Tile Arranges split-screen windows

Arrange Icons Arrange icons at the bottom of the window

Help

Contents... Opens the DSE 890 manual to search the Contents
Index... Opens the DSE 890 manual to search the Index
Search... Opens the DSE 890 manual to search for specific words
About DSE 890... Displays the version number and other information about DSE 890
General -

Data Sheets Opens data sheets about DSE 890
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